Feed Icon  

Contact

  • Bryant Likes
  • Send mail to the author(s) E-mail
  • twitter
  • View Bryant Likes's profile on LinkedIn
  • del.icio.us
Get Microsoft Silverlight
by clicking "Install Microsoft Silverlight" you accept the
Silverlight license agreement

Hosting By

Hot Topics

Tags

Open Source Projects

Archives

Ads

ECS RC410L/800-M Motherboard BIOS Hell

Posted in General | Vista at Wednesday, 29 November 2006 13:03 Pacific Standard Time

My youngest brother-in-law Boogs has a computer that I helped him to build. We have been trying to upgrade it with Windows Vista since RC1 was released but we always ended up with a BSOD. Today I spend some time trying to troubleshoot it and figured out the problem was with the ECS RC410L motherboard. ECS has a BIOS upgrade available on their website so I downloaded it and installed it with their utility. Everything went perfectly, the utility said everything was correct, and we rebooted. After the reboot we were greeted with a message telling us the date/time was not set and to hit F1. I hit F1, set the date/time and other important options and hit F10 to save and exit. Nothing. Hmmm. Clear the CMOS, system boots up, date/time not set, try setting only the date/time. Nothing. Try setting 100 different options different ways. Nothing.

Looks like I'm not the only one with this issue: http://forums.hexus.net/showthread.php?t=83863.

So I contact tech support, tell them my issue, point out that other people have the same issue, and I get the same cut/paste response:

Dear Valued Customer:

If the system doesn't bootup normally after the BIOS flash, the BIOS might have been corrupted, flash with a wrong file or was unsuccessful. Try clearing the CMOS jumper for at least 10 second with AC source unplug, longer time will allow the current or the memory to drain completely, reboot the system. If the system won't bootup on a floppy to re-program the BIOS then you need to contact your vendor for help recovering the BIOS.

Thank you for using ECS products

ECSUSA Technical Support

Now I'm no hardware expert (I used to do a lot of system building, but like Scott those skills have atrophied and I haven't kept up), but how do you clear the CMOS with the AC unplugged? I tried doing this just to test it out and it does nothing. From my experience you need to set the CMOS clearing jumper and turn on the PC with power for it to be cleared (nothing visible happens until you remove the jumper). Anyhow, I already ordered a new motherboard from Newegg and it is not an ECS motherboard as I'm guessing they will not be replacing the board for me. You can bet that I'll never buy an ECS motherboard again nor recommend thier products to anyone based on this really poor customer service. So if you're thinking about buying an ECS product, think again.

Technorati Tags: ECS, Hardware

Friday, 05 January 2007 15:38:50 (Pacific Standard Time, UTC-08:00)
Yes, to clear CMOS you must have power off and set the jumper to erase, this takes a little time. I usually give it at least 30 seconds to make sure residual voltages have drained. Then reset the jumper and boot the system, if ya don't do it like this it probably won't work. Erasing a CMOS has always been this way, ever since 1980 forward. Hope this helps.
Rod Williams
Saturday, 13 January 2007 13:12:16 (Pacific Standard Time, UTC-08:00)
You still need a solution

i got it

email me rohmc_c@yahoo.co.uk
ROHM
Thursday, 29 March 2007 09:16:51 (Pacific Standard Time, UTC-08:00)
the easiest way to clear any cmos is to unplug the computer and REMOVE the cmos battery. You probably only need to wait 5 seconds but its easiest to wait 30 seconds so you dont have to try again.
xeoph
Thursday, 29 March 2007 14:05:23 (Pacific Standard Time, UTC-08:00)
Good luck getting the ECS board to work with Vista; I messed with it for a few days (new BIOS, different DVD-ROMs, HDs, etc) and I always got the BSOD just as Vista startup kicks in. The error has something to do with an IDE issue.

I ended up yanking the board and replacing it with an aBit micro-ATX board; no problems.

I guess the RC410L/800-M is only good for XP and earlier installs!
Broo
Sunday, 08 April 2007 07:27:14 (Pacific Daylight Time, UTC-07:00)
I had the exact same problem when I tried to update the BIOS on the board. Eventually -- after a unhappy day of trying to find a solution -- either something I did worked, or fortune smiled on me, and it decided to boot again.

I tried a bunch of things. I cleared the CMOS as listed above, and then used the amibios recovery procedure to reflash the BIOS since it wouldn't boot
(i.e. copying the BIOS to a floppy, rename it as amiboot.rom and boot up holding Ctl + Home. Then hope to see the "Flash recovery started" and wait 5 inutes or so for it to recover -- I Googled for the Amibios error messages so I could interpret the beeps). After numerous tries of various BIOS images, eventually I was able to get it to 'sort of boot' -- enough to use the DOS bios flash utility to make one final flash with the new BIOS ... which appeared to work. I turned the RAM voltage setting in the BIOS to max, and I haven't had any trouble since ... but I won't flash a new BIOS on this machine again on a bet.
Miggy
Tuesday, 17 April 2007 00:00:41 (Pacific Daylight Time, UTC-07:00)
Same problem. ECS board stinks. Doesnt make a lot of sense as one would think a gig lan connection would be on the bleeding edge....but apparently not.
Chuck
Saturday, 19 May 2007 11:57:53 (Pacific Daylight Time, UTC-07:00)
try unplugging the keyboard and starting
ryan
Friday, 03 August 2007 15:30:14 (Pacific Daylight Time, UTC-07:00)
holy crap i wish i would have read this before i bought my mobo! i remember trying to get vista to work on my rc1, but i assumed it was a corrupt iso. now i bought the actual vista dvd and it dont work :( ive tried everything too, so im gonna go set my mobo on fire. brb
michael
Monday, 13 August 2007 11:36:57 (Pacific Daylight Time, UTC-07:00)
Heh, no wonder this motherboard was on sale at Fry's. Not only did they have a wrong price tag on it, I got it for $25.

I'm having problems having a DDR2 PC5300 667 MHz 1 GB RAM on it. It boots up fine when I have one of them installed. But with two, I get the BSOD. Then when I try Safe Mode, it tells me that my C:\Windows\System32\ntoskrnl.exe is corrupted or missing in a DOS-like black screen.

I think it's time I got a new motherboard.
RJ
Tuesday, 13 November 2007 23:40:53 (Pacific Standard Time, UTC-08:00)
I have the same issue: Flashed the bios to the latest on the website and guess what? No worky worky!!! Tech support was worthless, "You must send it in for an RMA and it will cost 25.00" BS!! so I bought another one on ebay and used that bios for a while. Just recently I got a wild hair up my butt and decided to do a hot swap bios flash. Fired up my pc with the bios chip just in far enough to make contact. once in windows I removed the chip and put in the one that was not working. Flashed it and it worked. I did make a backup of the original one first. I proceeded to flashed it to the most current...It worked so I did a hot swap on the other chip and flashed to the current bios update. Now neither one works!!! So the moral of the story. DO NOT UPDATE YOUR BIOS TO THE NEW ONE. I will have to try the ctrl-Home to see if that works.
Thanks for all the help on this guys!!
Curran
Saturday, 29 December 2007 15:00:43 (Pacific Standard Time, UTC-08:00)
thank god I read this I was going to buy af ew.
Mad Tony
Thursday, 24 January 2008 21:45:40 (Pacific Standard Time, UTC-08:00)
Probably not the problem you're having - but in case anyone else stumbles upon this entry and needs help. For some reason some of the BIOS updates seem to reset the CMOS into thinking it should use a USB device as the first boot option (clearly it tries floppy first and then ends up trying a USB drive).

Turn this off in the BIOS and it may boot (make a harddrive or CD drive the first boot device).

FYI - in this case your PC will get to the "verifying DMI pool data..." and stop.
Saturday, 16 August 2008 23:50:01 (Pacific Daylight Time, UTC-07:00)
Ha, i just got this error on my mobo, when i bought mine i thought ah why not i doubt everyone has problems with ECS... last time i EVER buy from them.
alex
Tuesday, 03 February 2009 01:37:19 (Pacific Standard Time, UTC-08:00)
WinXP ran great on it. I tried installing Vista with this motherboard and it got a blue screen during the install. Then I tried Vista on a different computer with an ASUS motherboard and it worked fine. Guess that ECS board is just for XP. BTW also tried Millenium but there's no drivers for it. If you have this motherboard stick with XP.
no bill gates here
Friday, 29 May 2009 02:31:54 (Pacific Daylight Time, UTC-07:00)
Im going to shoot myself,... Chalk me up for a new mobo,... same prob w/vista inst.
Micah
Friday, 29 May 2009 09:58:50 (Pacific Daylight Time, UTC-07:00)
This is th issue I have with my mobo and I still have NOT gotton a response from ECS
Posted : GMT 2009/05/27 19:49:54
Posted : GMT 2009/05/22 00:57:57
I built the computer a year ago(bought on 05-18-08) and have really just had issues from day one, I had to return my ram (patriot viper dd2 1066) cause the board wouldn't take it so I went out and got corsair ram(8gb) and came here for support and I also went to corsair and asked for help they were a 1000 times more helpful with ideas, none of the ideas got the board to run all 8 gb but still, anyways here is the new issue, my wife was on the internet and just surfing and the screen went black and said no signal on the monitor,

here is what I have tried so far
1.new pci vid card
2.different psu
3.new psu cord
4.new HDMI cord
5.different ram
6.new HD
7.unpluged everything from the mobo and left the power and HDMI hooked up and them the regular monitor cable

It all fires up but the monitor still sits at no signal. NOW I am really FED UP with this the board just rolled over a year and I got this crap going on NOW I bring this to you for help and if someone has any ideas to get it to work then great but if not I garentee that I will never buy or recommoned anyone to buy an ECS product again not worth the head ache

thanks for any help from the past and for this

and I have posted twice as you see the two different dates and times there tech service is the WORST tech support I have ever had to deal with.
lathen
Comments are closed.